DNS-Abfrage
Web & EntwicklungWie ist deine Domain im DNS eingerichtet?
Frage Adressen, Mailserver und weitere DNS-Einträge ab.
Deine Eingabe wird zur Prüfung an unseren Server gesendet. Wir protokollieren sie nicht. Öffentliche Prüfziele und Ergebnisse können kurz zwischengespeichert werden, um wiederholte Prüfungen zu vermeiden.
Zum Beispiel example.com, ohne https:// oder Pfad.
DNS-Antwort
Bereit zur Abfrage
Gib einen Hostnamen ein und wähle einen Eintragstyp.
- Eintragstyp
- Wert des Eintrags
- TTL (Sekunden)
Gesponserte Links
Frage Adressen, Mailserver und weitere DNS-Einträge ab.
Anleitung
- Gib einen öffentlichen Hostnamen wie example.com ohne Protokoll, Pfad oder Port ein.
- Wähle einen Eintragstyp und drücke Prüfen.
- Lies die Einträge und TTL-Werte ab. Wähle einen anderen Typ, um einen anderen Teil der Domain-Einrichtung zu prüfen.
So funktioniert es
DNS verknüpft Namen mit Informationen. A und AAAA liefern IP-Adressen, CNAME verweist auf einen anderen Namen, MX nennt Mailserver und NS Nameserver. TXT enthält Text, SOA beschreibt eine DNS-Zone und CAA legt Regeln für die Zertifikatsausstellung fest.
TTL ist die Zeit in Sekunden, für die eine DNS-Antwort zwischengespeichert werden darf. Zum Beispiel: 300 Sekunden ÷ 60 = 5 Minuten. Die Tabelle zeigt die gemeldete TTL für A und AAAA; bei anderen Eintragstypen ist die TTL-Spalte ausgeblendet. Der letzte SOA-Wert steuert das negative Caching und ist nicht die TTL des SOA-Eintrags.
Dies ist eine einzelne Abfrage über den Resolver unseres Servers. Zwischengespeicherte Antworten können andernorts abweichen. Fehlende Einträge eines Typs bedeuten nicht, dass die Website ausgefallen ist. Quellen: RFC 1035 (Eintragsformate und TTL), RFC 2308 (negatives Caching), RFC 8659 (CAA) und das IANA-Verzeichnis DNS Parameters.
Gesponserte Links
Häufige Fragen
Warum zeigt ein anderer DNS-Prüfer andere Einträge?
Resolver können unterschiedliche Antworten zwischengespeichert haben. Manche Domains liefern zudem je nach Standort andere Adressen.
Was unterscheidet fehlende Einträge von einem nicht existierenden Namen?
Fehlende Einträge bedeuten, dass der angefragte Typ nicht gefunden wurde. Eine Antwort für einen nicht existierenden Namen besagt, dass der abgefragte Name nicht existiert.
Kann ich Namen mit Unterstrich wie _dmarc.example.com prüfen?
Ja. Öffentliche DNS-Namen wie _dmarc.example.com sind erlaubt. IP-Adressen und interne Namen werden nicht akzeptiert.
Prüft das die weltweite DNS-Verbreitung?
Nein. Du siehst die Antwort eines Resolvers. Andere Netze können noch ältere Einträge im Cache haben.
Beweist ein A-Eintrag, dass eine Website funktioniert?
Nein. Ein A-Eintrag ordnet einem Namen eine IPv4-Adresse zu. Er testet den Webserver nicht.
Das könnte dir als Nächstes helfen
- WHOIS-AbfrageFinde Registrar, Datumsangaben und Nameserver aus WHOIS., privat, läuft auf deinem GerätWeb & EntwicklungPrüftoolNetzwerke
- HTTP-StatuscodesSchlage jeden HTTP-Statuscode nach: was 200, 301, 404, 429 oder 503 bedeutet, wann ein Server ihn sendet, ob Caches ihn speichern und welcher RFC ihn festlegt., privat, läuft auf deinem GerätWeb & EntwicklungNachschlagenNetzwerke
- Downloadzeit berechnenGib Dateigröße und Verbindungsgeschwindigkeit ein und sieh, wie lange ein Download oder Upload dauert., privat, läuft auf deinem GerätWeb & EntwicklungRechnerNetzwerke
- LändercodesISO-3166-Codes mit zwei Buchstaben, drei Buchstaben und Ziffern sowie Vorwahlen und Domains von 249 Ländern und Gebieten., privat, läuft auf deinem GerätAlltagNachschlagenNetzwerke
- Farbkontrast prüfenPrüfe den WCAG-Kontrast, sieh erfüllte Stufen und finde eine ähnliche Textfarbe, die die Anforderungen erfüllt., privat, läuft auf deinem GerätWeb & EntwicklungPrüftoolFarbe
- JSON-FormatiererFüge JSON ein, um Fehler zu finden, es übersichtlich zu formatieren oder zu komprimieren., privat, läuft auf deinem GerätWeb & EntwicklungPrüftoolUmrechnerKodierung
Mehr in Web & Entwicklung
Alle 18 Tools in Web & Entwicklung- PasswortgeneratorEin zufälliges Passwort auf deinem Gerät, mit Stärke in Bit. Nichts wird versendet., privat, läuft auf deinem Gerät
- BrowserinfoGemeldete Fakten zu Browser, Engine und Gerät., privat, läuft auf deinem Gerät
- Farben umrechnenWähle eine Farbe oder gib sie ein. Kopiere HEX, RGB, HSL, HWB oder OKLCH und sieh den nächsten CSS-Farbnamen., privat, läuft auf deinem Gerät
- Hash-GeneratorSHA-256-, SHA-512-, SHA-1- und MD5-Hashes für beliebige Texte, direkt in deinem Browser., privat, läuft auf deinem Gerät
- URL kodieren und dekodierenKodiere Text für Webadressen mit Prozentzeichen oder wandle %20 und andere Codes zurück in Klartext um., privat, läuft auf deinem Gerät
- UUID-GeneratorZufällige UUIDs der Version 4 oder zeitlich sortierbare Version 7, direkt auf deinem Gerät., privat, läuft auf deinem Gerät
Gerade beliebt
Gesponserte Links
Gesponserte Links
Gesponserte Links